Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 10,027
» Latest member: Jbroney
» Forum threads: 59,722
» Forum posts: 658,300

Full Statistics

Online Users
There are currently 197 online users.
» 0 Member(s) | 195 Guest(s)
Bing, Google

Latest Threads
Getting her out (finally!...
Forum: General
Last Post: Reserector
Yesterday, 05:15 PM
» Replies: 1
» Views: 12
Finally getting around to...
Forum: For Sale
Last Post: Reserector
05-16-2024, 08:56 AM
» Replies: 13
» Views: 108
What have you done for yo...
Forum: General
Last Post: Reserector
05-16-2024, 08:53 AM
» Replies: 1,371
» Views: 137,014
9toenelson Videos
Forum: Videos
Last Post: Reserector
05-02-2024, 06:55 AM
» Replies: 16
» Views: 568
Here's What Happened... (...
Forum: Here's What Happened...
Last Post: thesnowgod
04-27-2024, 08:28 PM
» Replies: 32
» Views: 1,015

 
  Here's What Happened... (Everyone Please Read This !!)
Posted by: Reserector - 09-08-2023, 08:54 AM - Forum: Here's What Happened... - Replies (32)

9/8/2023
If this is your first visit to the site, welcome!  Please register and make yourself at home.  Post in the New Member section and tell us a little about yourself.  Be among friends.  No need to read any further, really.

If you were already a member and are just re-discovering the forum, welcome back!  You are wondering why the site was missing for a while.  I will give a quick version, and then a more detailed one for those who like details and nerdy stuff.

The Quick Version:
The site went down (again) right around the time that the hosting fees were coming due.  Not sure why, but likely due to software updates on the hosting side that the site software wasn't compatible with. 
I took a look at it, hoping to fix it, as did one other member.  There was discussion about one of us taking over the Admin/hosting role from thesnowgod, and then letting that hosting site drop it.  The other member and I already have hosting for our own sites, so there would be no additional cost. 
I felt like I was the lesser qualified, so I waited while the other member worked on it.  He was able to get the old landing page ("Main site") back up, but not the forum.  I lost communication with him around that time.  Dunno
I had downloaded a copy of the site folders and database onto my PC at home before time ran out "just in case" we needed a backup.

Flash forward to a year later...
During and after the 2023 YZF600R Gap Meet, I came to realize how much everyone missed the website, so I decided to try to restore it from my backup copy.  My first attempts at reviving it failed.  Then I tried using a different forum software to "merge" the old site to.  It worked, but with some limitations.  That is what you see now.

What Do We Have?  What Don't We Have?

  • Members:  We have all of you!  Welcome Back!!
  • Threads and posts:  All of them, too.  We have the smilies, as well!  Cheers
  •  Avatars:  We have them, but you may need to reattach yours.  Go to 'User CP/Your Profile/Change Avatar'   They are all in a file that you can sift through to find yours.  Or you can create a new one. 
  • Photos: Linked photos are still linked, but the sad news is that Attachments didn't survive the trip.  Those photos are gone, unless you still have them and can add them back.  (I'll explain more in the Detailed Version.)
  • The Landing Page (Main site) with all of it's How-To's and other cool stuff is still the first thing you see when you go to YZF600R.com    This forum has its own Portal page, but you have to click Portal up top to access it.
  • 'How-To' Master List:  There are going to be broken links. Sad   I feel like this is the most important archive we ever had, and I will need help finding the 'How-To' posts so that we can re-link them.  Simply hit "Report" when you find a How-To post or thread, and then I or someone else will re-link it.
  • Ad-Free:  Thesnowgod has passed stewardship of the domain name to me, and I am deeply honored.  I will keep that bill paid as well.  That said, I will honor the original intent of the site and its developers and WE WILL REMAIN AD FREE!!
  • Tapatalk:  Search on Tapatalk for "YZF600R" and log in.

What Improved?
  • No more hosting fees.   Yay
  • We have a Dark Mode [User CP/Edit Options/Other Options/Board Style  Choose "Default" or "Dark" and then 'Update Options'
  • A new Cat-egory for members who are active in the Cat Community, but not actively riding a Cat.
  • Bigger Avatars.  150 x 150 (used to be 75 x 75)

So please go to the UserCP and update your profile.  You may need to update your birthday.  Check all that stuff out, and then start posting.
-Res-
_________________________________________________________________________________________

The Detailed, Nerdy Version
Since 2008, this forum has run on phpBB software.  It seems like a good platform.  The problem, however, is that it was on version 3.0 whereas phpBB3 is on version 3.3x.  The older version does not work with the latest versions of PHP and Apache, and so on.  Any one of those could have broken the site when Bluehost updated them automatically. 
I have done a LOT of reading on phpBB's site about migrating an existing site to a new server (basically what I was trying to do) and it did not work.  There are settings that need to be changed in the ACP before migrating, and with the site broken, I was unable to do that. 
There supposedly is a way to create a new phpBB3 site and then merge the old database with it, but it is a very complicated process (for me, at least.).  I started to do that, but found it overwhelming.  I also found out that Attachments won't re-link with the new version. 

I have been using MyBB for many years, now.  They have arguably the best "merge" function for converting other forums to MyBB.  In the case of phpBB3, however, there has never been a way to merge Avatars or Attachments.  I did find some work-arounds, such as dumping the avatars into a gallery that members can pick from.  Not the end of the world, there.  Undecided 
I was about to try someones half-baked coding for the Attachments when I saw a note from phpBB that said something to the effect of: "Be sure to change your settings in Filezilla to uncheck the box that transfers files with no extension as ASCII files.  They must be transferred as Binary.  Otherwise they will become corrupted and unfixable.  The only way to fix this problem is to change the settings and transfer them again."  Well, that ship has sailed, unfortunately.  The Attachment files are all corrupted.   Morph

The phpBB to MyBB merge recovered a ton, but at this point I have already spent a couple of weeks of evenings and hot summer days doing my best to get it back close to its former glory.  I just got an email from my hosting provider advising me that I have gone over my limit of activity for my current plan, so I need to chill for a bit.   Doh 

The Gallery folders still exist and I am experimenting with a way to make them visible, but no promises.

Print this item